Press "Enter" to skip to content

EIGRP? More like E-Ayeeeee-GRP! – CCNA/CCNP R&S/Enterprise Challenge

0

Last updated on 03/14/2020

I’ve got a post coming on how bad of an experience I had failing ROUTE twice! In the meantime, here’s an EIGRP challenge. Why, you ask? ….just, take it or leave it, alright?!

Anyway, here’s the challenge!

Challenge Scenario

You have three routers connected to a switch. You have the following configuration on the routers:

Configuration – Router 1

! Router 1 configuration
interface GigabitEthernet0/0
    description Link to Switch
    ip address 10.0.0.1 255.255.255.0
router eigrp 1
    network 10.0.0.1 0.0.0.0
    eigrp router-id 0.0.0.1
    no auto-summary

Configuration – Router 2

! Router 2 configuration
interface GigabitEthernet0/0
    description Link to Switch
    ip address 10.0.0.2 255.255.255.0
    ip access-group BlockEIGRP in
    ip access-group BlockEIGRP out
interface Loopback0
    description Advertise into EIGRP - Loopback Route
    ip address 2.2.2.2 255.255.255.255
router eigrp 1
    network 10.0.0.2 0.0.0.0
    network 2.2.2.2 0.0.0.0
    eigrp router-id 0.0.0.2
    no auto-summary
ip access-list extended BlockEIGRP
    1 deny eigrp 10.0.0.3 any
    2 deny eigrp any 10.0.0.3
    3 permit ip any any

Configuration – Router 3

! Router 3 configuration
interface GigabitEthernet0/0
    description Link to Switch
    ip address 10.0.0.3 255.255.255.0
    ip access-group BlockEIGRP in
    ip access-group BlockEIGRP out
router eigrp 1
    network 10.0.0.3 0.0.0.0
    eigrp router-id 0.0.0.3
    no auto-summary
ip access-list extended BlockEIGRP
    1 deny eigrp 10.0.0.2 any
    2 deny eigrp any 10.0.0.2
    3 permit ip any any

You discover after this configuration that the route to 2.2.2.2/32 doesn’t appear in Router3’s EIGRP topology table. Why is this? (Hint: The solution could be to remove the access-lists, but it’s not the solution I am looking for.)


Answer found below!

Reveal answer here!
The reason that the route to 2.2.2.2/32 doesn’t appear in Router3’s EIGRP topology table is because Router1, with its default EIGRP configuration, will have split horizon enabled.

Split horizon is a technology that prevents a route that came in on an update on one interface from being re-advertised out of the interface. This is a routing loop-prevention mechanism, as it can be assumed in a lot of topologies that if a route was received on an interface, that the other side of that interface knows about the route. That works if the interface is a direct connection between two routers.

However, for interfaces leading to multi-access links, split horizon can often cause problems, as can be seen in this case. All the routers are connected to a switch, creating a multi-access segment. Ordinarily, this would result in no problem because the routers would form EIGRP routing neighborships with all routers on the switch. However, in this case, I have artificially made a hub-and-spoke topology by defining extended ACLs on Router2 and Router3 that block EIGRP messages from each other, thus ensuring that Router2 and Router3 do not peer with each other. This means that when Router2 advertises its route, it only gets advertised to Router1. When Router1 goes to advertise this route out to its other neighbors, however, the EIGRP routing process detects that the route came in on the same interface that it is attempting to advertise it out and as such, split horizon intervenes and prohibits this from occurring.


Alrighty, now go study, lads! You’ve got 21 days! Good luck!

Again, blog post coming on ROUTE (and why it’s such a little whiny baby) and what I’ve got planned coming next! Should be lovely. Hope to see you guys when I make that post!

You’re still here? I told you to go study, gosh darn it! 🙂

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.