Press "Enter" to skip to content

I Love Twitch Streaming! + Some PBR Fun

0

Last updated on 03/14/2020

So…my last post were two awesomely awesome CCNA challenges…or whatever the hell I called it!

It’s 12 AM at this point…don’t expect me to remember anything anymore.

Anyway – I’ve fallen in love with Twitch streaming now, at least when there’s an audience. Twitch streaming and interacting with the audience through a combination of Twitch chat and Discord voice chat is so awesome! I look forward to being a more active technology Twitch streamer and maybe even start uploading some YouTube videos with technical content.

Working on a few blog posts as well as trying to get my CCNP. Failed ROUTE for reasons that I’m still unaware of, so I’m working on getting ROUTE and TSHOOT out of the way so that I can both have my CCNP and write ridiculously snarky blog posts.

In the meantime, here’s some policy based routing fun!

! Router 1 configuration
interface GigabitEthernet0/0
   description Connection to Router 3
   ip address 10.13.0.1 255.255.255.252
interface Loopback 0
   ip address 1.1.1.1 255.255.255.255
router eigrp 1
   network 10.13.0.1 0.0.0.0
   network 1.1.1.1 0.0.0.0
   no auto-summary
! Router 2 configuration
interface GigabitEthernet0/0
   description Connection to Router 3
   ip address 10.23.0.1 255.255.255.252
router eigrp 1
   network 10.23.0.1 0.0.0.0
   no auto-summary    
! Router 3 configuration
interface GigabitEthernet0/0
   description Connection to Router 1
   ip address 10.13.0.2 255.255.255.252
!
interface GigabitEthernet0/1
   description Connection to Router 2
   ip address 10.23.0.2 255.255.255.252
!
interface GigabitEthernet0/2
   description Connection to Host 1
   ip address 192.168.1.254 255.255.255.0
   ip policy route-map MeowIsAPoopyHead
!
router eigrp 1
   network 10.13.0.2 0.0.0.0
   network 10.23.0.2 0.0.0.0
   network 192.168.1.254 0.0.0.0
   no auto-summary
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
route-map MeowIsAPoopyHead permit 10
   match ip address 1
   set ip next-hop 10.23.0.1
PC1>ping 1.1.1.1
PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: icmp_seq=0 ttl=64 time=0.033 ms
64 bytes from 1.1.1.1: icmp_seq=1 ttl=64 time=0.033 ms
64 bytes from 1.1.1.1: icmp_seq=2 ttl=64 time=0.033 ms
64 bytes from 1.1.1.1: icmp_seq=3 ttl=64 time=0.036 ms

PC1>tracert 1.1.1.1
Tracing route to 1.1.1.1 [1.1.1.1]
over a maximum of 30 hops:

  1     1 ms    <1 ms    <1 ms  192.168.1.254
  2     1 ms    <1 ms    <1 ms  10.23.0.1
  3     1 ms    <1 ms    <1 ms  10.23.0.2
  4     1 ms    <1 ms    <1 ms  10.13.0.1
  5     1 ms    <1 ms    <1 ms  1.1.1.1

Yay! PBR is working! Admittedly though, this is a fairly pointless demonstration of PBR because this is a scenario where Routers 1 and 2 don’t have a direct connection to each other and as such, even though Router 3 sets the next-hop of Host 1 to be the IP address of Router 2 instead of Router 1 (where the loopback lives), Router 2 learns of the route to the loopback address on Router 1 (1.1.1.1) through EIGRP only from Router3. Therefore, when Router2 goes to route 1.1.1.1, it routes it back through Router3 and Router3’s routing table kicks in.

With that being said though, you definitely could use PBR for some real useful applications and this is more of a proof of concept.

Stop making me defend myself to you! My labs are perfect. 😉

You guys have a great time, catch ya later in my next blog post (which is probably going to be the one that’s my longest yet – the detailed experience of taking the ROUTE exam at least twice – got my second administration on 1/30, wish me luck! Hope I don’t fail!)

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.